Elevated queue times for API conversion jobs

Incident Report for Zamzar

Resolved

This incident is now resolved - queue times are back to normal.
Posted Jul 03, 2026 - 20:53 UTC

Monitoring

Queue times are now coming down, we will update again here once the incident is resolved.
Posted Jul 03, 2026 - 20:28 UTC

Identified

The issue has been identified and we are working to resolve.
Posted Jul 03, 2026 - 20:16 UTC

Investigating

We are observing elevated queue times for API conversion jobs for some customers.

Our engineer team are currently investigating as soon as we have an update we will post here.
Posted Jul 03, 2026 - 20:15 UTC
This incident affected: Developer API.